Okay
  Public Ticket #2803987
jQuery Migrate Helper
Open

Comments

  • C. started the conversation
    I am still getting this error. Can you give me a fix please?jQuery Migrate Helper

    Right now, you are using a plugin to support some old code in this website’s jQuery JavaScript library. That code is deprecated, meaning it is basically obsolete and is losing the support of your themes and plugins and WordPress itself. This plugin, called Enable jQuery Migrate Helper, is not a fix. It is a temporary solution to give your plugin and theme authors time to update.

    If you get warnings, please check for updated versions of the plugin or theme that generated the warning. There will very likely be one you can install. When you have updated your plugins and themes, and there are no more warnings, please deactivate Enable jQuery Migrate Helper.

    You are currently using a legacy version of jQuery. It has no support and doesn’t receive security updates. Please upgrade as soon as possible.

  •  88
    djwd replied

    HI there,

    what error are you talking about? 

    jQuery Migrate Helper is a fix as long as it fixes issues. Dropping support for jQuery Migrate would be very complicated at this time unfortunately as it would need a total re-write of many parts of the theme and especially some bundled plugins which would need to get dropped as well.

    Regards
    djwd

  • C. replied

    So as long as jQuery Migrate Helper is installed the theme will work still? I want to make sure one day the theme stops working due to this.

  •  88
    djwd replied

    Yes it will mostly likely continue to work for years to come as long as migrate is loaded, still looking to hire someone to work on an update at the moment. Stay tuned

    Regards
    djwd